有问题先找AI

要点:问 AI 的时候包括完整上下文、报错等,若有截图尽量完整提供,不明之处继续追问。

用法举例:

  • 问「怎么配置阿里云安全组放行所有端口?」
  • 问「Windows 下如何使用 ssh,常用命令是什么?」
  • 贴 nginx 配置文件、完整错误截图等,问「为什么反代博客无法访问,XXX(具体问题)」
  • 贴本文档全部内容,问「我是云计算方面的新手,教我一步步完成这个配置」
  • 贴本文档全部内容,然后再单独贴其中某一句话,问「这句话啥意思」

一、开通阿里云

领取高校学生权益

访问 阿里云高校计划 ,按照页面指引登录并完成学生认证,领取高校学生通用权益(300元抵扣金)。

高校计划
高校计划

购买云服务器

购买一台以下配置的云服务器ECS:

配置参数
配置参数

登录云服务器。有多种方式登录到云服务器,你可以选择任意一种你喜欢的,只要能成功登录即可。以下是一种推荐的方式:

  • 使用MobaXTerm软件

二、部署nginx

安装 Nginx,查看服务状态

云服务器可以用来做许多好玩的事情。在云服务器部署自己的博客是最常见的应用方式。在本次作业中,我们将通过 Nginx 部署一个 HTML 页面,然后通过浏览器访问它。

登录到云服务器后,执行以下命令:

sudo apt update # 更新软件包列表(由于我们以 root 账户登录,sudo 其实是不必要的)

sudo apt install -y nginx # 安装 nginx

安装完毕后,执行以下命令查看 Nginx 服务的运行状态:

systemctl status nginx

服务状态
服务状态

可以看到服务处于 active(running) 状态,表示 Nginx 已经启动成功并正常运行在云服务器的 80 端口上。

理论上,我们使用在自己电脑上的浏览器访问云服务器的公网IP(即 http://<你的服务器公网IP>),也显示与上图 HTML 文本相同的内容。

但经过测试发现,我们还不能打开页面。这是因为阿里云服务器对入方向(外界访问云服务器)的端口有严格的管理,默认情况下只开启了少量的端口,其中并不包括我们要使用的 80 端口。接下来我们还需要在云服务器控制台配置安全组规则,开启 80 端口。

配置安全组规则,开启 80 端口

阅读 阿里云文档 ,按照其中的教程打开安全组页面,在【入方向】添加并保存规则,如下图所示:

安全组
安全组

通过浏览器访问云服务器上的网页

规则添加完毕后,再次通过浏览器访问 http://<你的服务器公网IP>,如果一切顺利,应出现 Nginx 默认欢迎页。

浏览器页面
浏览器页面